管理筆記本

本文說明如何管理 BigQuery 中的 Colab Enterprise 筆記本,包括如何查看、比較、還原及刪除筆記本。

本文也說明如何在 Knowledge Catalog 查看及管理筆記本中繼資料。

Notebooks 是 BigQuery Studio 程式碼資產,採用 Dataform 技術。

事前準備

  1. 建立筆記本。
  2. 如要在 Knowledge Catalog 中管理筆記本中繼資料,請確認 Cloud de Confiance 專案已啟用 Dataplex API。

所需權限

如要共用筆記本,您必須具備下列 Identity and Access Management (IAM) 角色:

如要儲存及刪除筆記本,您必須具備下列 IAM 角色:

如要使用筆記本修訂版本,您必須具備下列 IAM 角色:

如要進一步瞭解 BigQuery IAM,請參閱「使用 IAM 控管存取權」。

如要在 Knowledge Catalog 中管理筆記本中繼資料,請確認您具備必要的 Knowledge Catalog 角色。

授予筆記本存取權

如要授予其他使用者筆記本存取權,請將這些使用者新增至適當的 IAM 角色。

  1. 前往 Cloud de Confiance 控制台的「BigQuery」BigQuery頁面。

    前往「BigQuery」

  2. 點選左側窗格中的 「Explorer」。

    醒目顯示的「Explorer」窗格按鈕。

    如果沒有看到左側窗格,請按一下 「Expand left pane」(展開左側窗格),開啟窗格。

  3. 在「Explorer」窗格中展開專案,然後點選「Notebooks」。

  4. 找出要授予存取權的筆記本。

  5. 按一下筆記本旁的「Open actions」(開啟動作) 圖示 ,然後點選「Share」(共用)。

  6. 在「共用權限」窗格中,按一下「新增使用者/群組」。

  7. 在「New principals」(新增主體) 欄位中輸入主體。

  8. 在「Role」(角色) 清單中,選取下列其中一個角色:

  9. 選用:如要查看完整的角色清單和進階共用設定,請按一下「Advanced sharing」(進階共用)。

  10. 按一下 [儲存]。

  11. 如要返回筆記本資訊頁面,請按一下「Close」(關閉)。

共用筆記本

如要與其他使用者共用筆記本,可以生成並分享筆記本連結。如要讓其他使用者查看您共用的筆記本,您必須先授予筆記本存取權。

如要執行筆記本,使用者必須有權存取筆記本存取的資料。詳情請參閱「授予資料集存取權」。

  1. 前往 Cloud de Confiance 控制台的「BigQuery」BigQuery頁面。

    前往「BigQuery」

  2. 點選左側窗格中的 「Explorer」。

    醒目顯示的「Explorer」窗格按鈕。

    如果沒有看到左側窗格,請按一下 「Expand left pane」(展開左側窗格),開啟窗格。

  3. 在「Explorer」窗格中展開專案,然後點選「Notebooks」。

  4. 找出要共用的筆記本。您可以使用搜尋功能或篩選器尋找筆記本。

  5. 按一下筆記本旁的「查看動作」圖示 ,然後依序點選「共用」>「複製連結」。

  6. 與其他使用者分享連結。

停用筆記本輸出內容儲存功能

您可以停用筆記本輸出內容儲存功能,防止與其他有權存取筆記本檔案的使用者共用已儲存的筆記本輸出內容。

如果停用所選筆記本的輸出內容儲存功能,BigQuery 會刪除筆記本檔案中儲存的所有輸出內容,且不會儲存後續執行的輸出內容。

不過,有權存取筆記本的使用者仍可透過下列方式查看輸出內容:

  • 執行筆記本,查看目前的輸出內容。系統不會儲存這項輸出內容。
  • 在修訂版本記錄中,查看筆記本的封存版本和輸出內容。

如要停用所選筆記本的輸出內容儲存功能,請按照下列步驟操作:

  1. 前往 Cloud de Confiance 控制台的「BigQuery」BigQuery頁面。

    前往「BigQuery」

  2. 點選左側窗格中的 「Explorer」。

    醒目顯示的「Explorer」窗格按鈕。

    如果沒有看到左側窗格,請按一下 「Expand left pane」(展開左側窗格),開啟窗格。

  3. 在「Explorer」窗格中展開專案,然後點選「Notebooks」。

  4. 按一下要停用輸出內容儲存功能的筆記本。

  5. 如要展開選單列,請按一下 keyboard_arrow_down「切換標頭顯示設定」。

  6. 依序點選「編輯」 > 「筆記本設定」。

  7. 在「Notebook settings」(筆記本設定) 視窗中,選取「Omit code cell output when saving this notebook」(儲存這個筆記本時,忽略程式碼儲存格輸出內容)。

  8. 按一下 [儲存]。

  9. 按一下「重新載入」。

解決衝突

如果您和其他使用者在筆記本中進行了不一致的變更,服務會引發 Automatic saving failed. This file was updated remotely or in another tab. 錯誤,並提供 Show diff 連結。如要解決衝突,請按照下列步驟操作:

  1. 按一下「Show diff」連結。「Review remote changes」對話方塊隨即開啟。
  2. 選用:如要比較筆記本原始碼,請勾選「Raw source」(原始碼) 核取方塊。
  3. 選用:如要比較內嵌版本,而非在不同窗格中比較,請勾選「Inline diff」(內嵌差異) 核取方塊。
  4. 查看變更並決定要保留哪些內容,必要時可修改輸入內容。
  5. 按一下「儲存變更」。

查看所有筆記本

如要查看專案中所有筆記本的清單,請按照下列步驟操作:

  1. 前往 Cloud de Confiance 控制台的「BigQuery」BigQuery頁面。

    前往「BigQuery」

  2. 點選左側窗格中的 「Explorer」。

    醒目顯示的「Explorer」窗格按鈕。

    如果沒有看到左側窗格,請按一下 「Expand left pane」(展開左側窗格),開啟窗格。

  3. 在「Explorer」窗格中,按一下「Notebooks」旁邊的 「View actions」(查看動作),然後執行下列任一操作:

  • 如要在目前的分頁中開啟清單,請按一下「顯示全部」。
  • 如要在新分頁中開啟清單,請依序點選「全部顯示」 >「新分頁」。
  • 如要在分割分頁中開啟清單,請依序按一下「全部顯示」 >「分割分頁」。

查看筆記本中繼資料

如要查看筆記本中繼資料,請按照下列步驟操作:

  1. 前往 Cloud de Confiance 控制台的「BigQuery」BigQuery頁面。

    前往「BigQuery」

  2. 點選左側窗格中的 「Explorer」。

    醒目顯示的「Explorer」窗格按鈕。

  3. 在「Explorer」窗格中展開專案,然後點選「Notebooks」。

  4. 按一下要查看中繼資料的筆記本名稱。

  5. 查看摘要詳細資料,瞭解筆記本的相關資訊,例如用於資料的區域和上次修改日期。

使用筆記本版本

您可以選擇在存放區內或外建立筆記本。Notebook 的版本管理方式會因 Notebook 的位置而異。

存放區中的 Notebook 版本管理

存放區是位於 BigQuery 或第三方供應商的 Git 存放區。您可以使用存放區中的工作區,對筆記本執行版本管控。詳情請參閱「使用檔案版本管控功能」。

在存放區外管理 Notebook 版本

請參閱下列各節,瞭解如何查看、比較及還原筆記本版本。

查看筆記本版本

如要查看筆記本版本,請按照下列步驟操作:

  1. 前往 Cloud de Confiance 控制台的「BigQuery」BigQuery頁面。

    前往「BigQuery」

  2. 點選左側窗格中的 「Explorer」。

    醒目顯示的「Explorer」窗格按鈕。

  3. 在「Explorer」窗格中展開專案,然後按一下「Notebooks」。按一下要查看版本記錄的筆記本名稱。

  4. 如要依日期遞減順序查看筆記本版本清單,請按一下「Version history」(版本記錄) 圖示 。

比較筆記本版本

如要比較筆記本版本,請按照下列步驟操作:

  1. 前往 Cloud de Confiance 控制台的「BigQuery」BigQuery頁面。

    前往「BigQuery」

  2. 點選左側窗格中的 「Explorer」。

    醒目顯示的「Explorer」窗格按鈕。

  3. 在「Explorer」窗格中展開專案,然後點選「Notebooks」。

  4. 按一下要比較版本資訊的筆記本名稱。

  5. 按一下 「版本記錄」。

  6. 按一下筆記本版本旁的 「View actions」(查看動作),然後點選「Compare」(比較)。比較窗格隨即開啟,比較您選取的筆記本版本與目前的筆記本版本。

  7. 選用:如要並排比較版本,而非在不同窗格中比較,請依序按一下「Compare」(比較) 和「Inline」(並排)。

  8. 選用:如要比較版本的原始碼,請依序按一下「Compare」(比較) 和「Show raw source」(顯示原始碼)。

  9. 選用:如要在筆記本中隱藏指令輸出內容,請按一下「Compare」(比較),然後取消選取「Show output」(顯示輸出內容)。

還原筆記本版本

從比較窗格還原筆記本版本,可讓您比較筆記本的目前和先前版本,再選擇還原先前版本。還原筆記本會建立新版本,而非覆寫目前版本。不會遺失任何版本記錄。

  1. 前往 Cloud de Confiance 控制台的「BigQuery」BigQuery頁面。

    前往「BigQuery」

  2. 點選左側窗格中的 「Explorer」。

    醒目顯示的「Explorer」窗格按鈕。

  3. 在「Explorer」窗格中展開專案,然後點選「Notebooks」。

  4. 按一下要還原先前版本的筆記本名稱。

  5. 按一下 「版本記錄」。

  6. 按一下版本旁的 「View actions」(查看動作),然後點選「Compare」(比較)。比較窗格隨即開啟,比較您選取的筆記本版本與最新筆記本版本。

  7. 如要在比較後還原先前的筆記本版本,請按一下「Restore」(還原)。

  8. 按一下「確認」。

重新命名筆記本

如要重新命名筆記本,請按照下列步驟操作:

  1. 前往 Cloud de Confiance 控制台的「BigQuery」頁面。

    前往「BigQuery」

  2. 點選左側窗格中的 「Explorer」。

    醒目顯示的「Explorer」窗格按鈕。

  3. 在「Explorer」窗格中展開專案,然後點選「Notebooks」。

  4. 點選要重新命名的筆記本。

  5. 按一下 keyboard_arrow_down「Toggle header visibility」(切換標頭顯示設定),展開選單列。

  6. 依序點選「檔案」 > 「重新命名」。

  7. 在「Rename notebook」(重新命名筆記本) 對話方塊中,輸入筆記本名稱,然後按一下「Rename」(重新命名)。

下載筆記本

如要下載筆記本,請按照下列步驟操作:

  1. 前往 Cloud de Confiance 控制台的「BigQuery」BigQuery頁面。

    前往「BigQuery」

  2. 點選左側窗格中的 「Explorer」。

    醒目顯示的「Explorer」窗格按鈕。

  3. 在「Explorer」窗格中展開專案,然後點選「Notebooks」。

  4. 按一下要下載的筆記本名稱。您可以使用搜尋功能或篩選器尋找筆記本。

  5. 展開選單列,然後前往「檔案」選單:

    筆記本選單列

  6. 選取「下載」,然後選取要下載的檔案類型。

刪除筆記本

如要刪除筆記本,請按照下列步驟操作:

  1. 前往 Cloud de Confiance 控制台的「BigQuery」BigQuery頁面。

    前往「BigQuery」

  2. 點選左側窗格中的 「Explorer」。

    醒目顯示的「Explorer」窗格按鈕。

  3. 在「Explorer」窗格中展開專案,然後點選「Notebooks」。

  4. 找出要刪除的筆記本。

  5. 按一下筆記本旁的 「View actions」(查看動作),然後點選「Delete」(刪除)。

  6. 在對話方塊中輸入 delete,確認刪除。

  7. 點選「刪除」。

在 Knowledge Catalog 管理中繼資料

Knowledge Catalog 可讓您儲存及管理 Notebook 的中繼資料。Notebooks 預設在 Knowledge Catalog 中提供,不需額外設定。

您可以使用 Knowledge Catalog,管理所有 BigQuery 位置中的筆記本。在 Knowledge Catalog 中管理筆記本時,須遵守 Knowledge Catalog 配額和限制,以及 Knowledge Catalog 定價。

Knowledge Catalog 會自動從筆記本擷取下列中繼資料:

  • 資料資產名稱
  • 資料資產父項
  • 資料資產位置
  • 資料資產類型
  • 對應的 Cloud de Confiance 專案

Knowledge Catalog 會將筆記本記錄為項目,並包含下列項目值:

系統項目群組
筆記本的系統項目群組為 @dataform。如要在 Knowledge Catalog 中查看筆記本項目的詳細資料,您必須查看 dataform 系統項目群組。如要瞭解如何查看項目群組中所有項目的清單,請參閱 Knowledge Catalog 說明文件中的「查看項目群組的詳細資料」。
系統項目類型
筆記本的系統項目類型為 dataform-code-asset。如要查看筆記本詳細資料,請查看 dataform-code-asset 系統項目類型,使用切面篩選器篩選結果,並將 dataform-code-asset 切面中的 type 欄位設為 NOTEBOOK。然後選取該筆記本中的項目。 如要瞭解如何查看所選項目類型的詳細資料,請參閱 Knowledge Catalog 說明文件中的「查看項目類型的詳細資料」。如要瞭解如何查看所選項目的詳細資料,請參閱 Knowledge Catalog 說明文件中的「查看項目詳細資料」一節。
系統切面類型
筆記本的系統切面類型為 dataform-code-asset。如要使用切面為筆記本項目加上註解,為 Knowledge Catalog 中的筆記本提供額外背景資訊,請查看 dataform-code-asset 切面類型,使用切面篩選器篩選結果,並將 dataform-code-asset 切面中的 type 欄位設為 NOTEBOOK。如要瞭解如何使用切面為項目加上註解,請參閱 Knowledge Catalog 說明文件中的「管理切面並充實中繼資料」。
類型
資料畫布的類型為 NOTEBOOK。這種類型可讓您在切面篩選器中使用 aspect:dataplex-types.global.dataform-code-asset.type=NOTEBOOK 查詢,篩選 dataform-code-asset 系統項目類型和 dataform-code-asset 切面類型中的筆記本。

如要瞭解如何在 Knowledge Catalog 搜尋資產,請參閱 Knowledge Catalog 說明文件中的「在 Knowledge Catalog 搜尋資料資產」。

疑難排解

詳情請參閱「排解 Colab Enterprise 問題」。

後續步驟